Попробуйте бесплатно!

Требования к хостингу для интернет-магазина

Минимальные требования, которым должен соответствовать тарифный план хостинга.
  1. PHP версии от 5.0.5 или выше. Рекомендуется 5.1.2 или выше.

  2. СУБД MySQL версии от 5.0.3 или выше. Для работы скрипта нужна одна база данных MySQL. Данные скрипта также могут быть установлены в базу данных, уже используемую другим приложением.

Если есть возможность выбора хостинга на Unix платформе и на Windows платформе, не задумываясь, выбирайте хостинг на Unix платформе. Для PHP скриптов предпочтительным является Unix хостинг.

Необязательные дополнительные требования

Если планируете включить имитацию статичных страниц (ЧПУ), тогда ваш хостинг должен поддерживать модуль mod_rewrite (rewrite_module) веб-сервера Apache или nginx. Большинство хостингов на Unix платформе поддерживают этот модуль. Поддержка модуля mod_rewrite не обязательна, скрипт будет работать и без неё, только нельзя будет включить имитацию статичных страниц.
Узнать, поддерживается ли mod_rewrite вы можете в технической поддержке хостинга или в описании тарифного плана хостинга (в описаниях тарифных планов о поддержке mod_rewrite почти нигде не пишут).

Для автоматического создания маленьких превью изображений при загрузке больших, а также для генерации защитной картинки в форме регистрации, скрипт использует расширение GD для PHP. Для включения вышеописанных функций, тарифный план хостинга должен поддерживать этот модуль. На большинстве хостингов включено расширение GD.
Смотрите также:

Обзор хостинг-провайдеров.

Отзывы пользователей о хостинг-провайдерах.